EazyLink2 V1.0 Release Notes

26th August 2015 / 16th September 2015 / 4th October

EazyLink2 V1.0(.3) is finally done. The QT libraries being used is v5.2.1 - v5.4.2 for all platforms. Many improvements and bug fixes since beta 3 and beta 5. The cherry for v1.0 release is support for Raspberry Pi  (all models, Arm 32bit) and Windows 7+ (Intel 64 bit executable). This final version has been extensively tested with both classic RS-232 cable and many USB serial adapters on all Z88 ROM releases.

This release supports 38400 BPS, when used Cambridge Z88 OZ V4.5 ROM release or later.

 

PlatformVersionSizeAddedInstallation notesDownload Link
Eazylink2_1.0.3-WindowsXP-installer.exe18.5MB2015/10/04

Download EXE installer to desktop, double-click to start installation. Supported to run on Windows XP SP2+ and Windows Vista (32bit). Uses Qt v5.4.1 libraries.

 

Eazylink2_1.0.3-Windows7-installer.exe19.8MB2015/10/04

Download EXE installer to desktop, double-click to start installation. Supported to run on Windows7 and newer (64bit). Uses Qt v5.4.1 libraries.

 

Eazylink2_1.0.3-MACOSX.zip

9.6MB2016/08/22Mac OS X 10.8 and newer. Uses Qt v5.7 libraries.
Download Zip archive to desktop, double-click to extract application. Drag to Application folder or run from extracted directory.  Use CTRL and double-click on 10.8 (Mountain Lion) to run (this is an unsigned application).  
Eazylink2_1.0.3-Linux_i386-installer.run23.7MB2015/10/04

All Linux distributions, Intel 32bit. Uses Qt v5.4.1 libraries.
Download RUN installer to Gnome / KDE (or other X-Windows based) desktop, apply chmod +x, then execute from command line or desktop file browser. Supported to install and run on DEB package distributions like Debian & Ubuntu, RPM package distributions like Fedora, Mandriva, OpenSuse and PcLinuxOS, using kernel v2.6 or later.

This is a generic installer, so If the application does not start, please use the native package installers or compile from source.

Eazylink2_1.0.3-Linux_ix64-installer.run24.9MB2015/10/04

All Linux distributions, Intel 64bit. Uses Qt v5.4.1 libraries.
Download RUN installer to Gnome / KDE (or other X-Windows based) desktop, apply chmod +x, then execute from command line or desktop file browser. Supported to install and run on DEB package distributions like Debian & Ubuntu, RPM package distributions like Fedora, Mandriva, OpenSuse and PcLinuxOS, using kernel v2.6 or later.

This is a generic installer, so If the application does not start, please use the native package installers or compile from source.

Eazylink2_1.0.3~Raspbian~Jessie1_armhf.deb327.1kB2015/10/06

For Rasperry Pi Linux (Raspbian "Jessie", Arm). Uses Debian's Qt v5.3.2 libraries. Download Debian installation package archive.

Install using the following instructions:

Use Linux command shell to install Eazylink2
sudo dpkg -i eazylink2_1.0.3~1raspbian~jessie_armhf.deb


Eazylink2_1.0.3~Raspbian~Wheezy1_armhf.deb6.7MB2015/10/06

For Rasperry Pi Linux (Raspbian "Wheezy", Arm).

Download Debian installation package archive. Uses statically linked Qt v5.4.2 libraries.

Install using the following instructions:

Use Linux command shell to install Eazylink2
sudo dpkg -i eazylink2_1.0.3~Raspbian~wheezy1_armhf.deb


Ubuntu PPA repositories for Eazylink2
 2015/09/27

Install Eazylink2 executables via registering of PPA repository for Ubuntu 14.04 (and Linux Mint 17.x), Ubuntu 15.04 and Ubuntu 15.10. Available for Intel 32bit, Intel amd64 (64bit) and Arm (32bit).

Install using the following instructions:

Use Linux command shell to install Eazylink2
sudo add-apt-repository ppa:cambridgez88/eazylink2
sudo apt-get update
sudo apt-get install eazylink2

More information about packages is available here:

https://launchpad.net/~cambridgez88/+archive/ubuntu/eazylink2

Eazylink2_1.0.3~Debian8~jessie1_i386.deb364.2kB2015/10/08Installable binary package for Debian 8.x "Jessie", Intel 32bit. Uses Qt v5.3.2 libraries.
Download Debian package to your desktop. Install via prompt from browser (Gui Qapt) or from command line (or QApt), sudo dpkg -i Eazylink2_1.0.3~Debian8~jessie1_i386.deb.
Eazylink2_1.0.3~Debian8~jessie1_amd64.deb356.8kB2015/10/06Installable binary package for Debian 8.x "Jessie", Intel amd64 (64bit). Uses Qt v5.3.2 libraries.
Download Debian package to your desktop. Install via prompt from browser (Gui Qapt) or from command line (or QApt),
dpkg -i Eazylink2_1.0.3~Debian8~jessie1_amd64.deb.
Eazylink2_1.0.3.deb.src.tar.gz810.5kB2015/10/06

Debian source package. To be used for xUbuntu 14.04+ or other recent Debian architectures, in order to re-compile and create native package installer. Please share any builds!

Qt5 v5.2.x or later development libraries must be available on the distribution. build-debsrc-readme.txt is available inside archive for setup and build instructions.

Eazylink2_1.0.3-Sourcecode.zip843.5kB2015/10/04

Platform independent source code for EazyLink2 application. De-compress archive, then compile using QT SDK 5.4 (all platforms - download links HERE).

The source code is also available in our Git repository, HERE: https://gitlab.com/bits4fun/eazylink2

 

Work done in this release

Below you will see the list of work and features with all the technical details, that we have done. Click on the links to read issue contents:

key summary type created updated due assignee reporter priority status resolution
Loading...
Refresh